Scheduled Maintenance Event Atlanta Data Center

Scheduled for Aug 18, 23:00 PDT  -  Aug 19, 03:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 24, 2026 - 09:06 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 24, 2026 - 08:44 PDT

Scheduled

Granite Telecommunications has scheduled a core network maintenance event in our Atlanta, GA data center for the Granite EPIK service. This maintenance includes updates to the network infrastructure to support continued service improvements.

Scheduled Start Date & Time: 8/18/2026 02:00 AM Eastern Time
Scheduled End Date & Time: 8/19/2026 06:00 AM Eastern Time

Maintenance Duration: 4 hours
Expected Downtime: None

While no service interruption is expected, this is a controlled maintenance window to allow for rapid response should any issues arise.
Posted Jul 24, 2026 - 08:44 PDT
This scheduled maintenance affects: MyEPIK Portal, Carrier Services (EPIK Carrier Services), and EPIK Services (EPIK Voice Services).